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Creating a Customer
Click the NEW button at the bottom of the Customers List
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Enter the Customer Name (Required) and other basic information

You can set the Address, Category, AR Account, Division, Buyer Filter, and Discount here. These
can also be edited in the Customer Overview screen.

Required Fields

Name: The name of the business / customer you are selling to. This name must be unique.
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Enter the Customer Credit information

Here you can set the Currency for this customer, the Credit Status, Credit Limit, and Credit Terms.
These can also be edited in the Customer Overview screen.

Note

These fields will act as defaults for orders, but many fields can be overridden at the order entry level
such as Credit Status, Currency, and Credit Terms.
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Customer Overview
The Overview tab displays general information for a customer.

Fields

Division: (configure under Settings > Divisions) Used to specify which section of your company a
customer orders from.

Category: Used to group styles together for searching/organization purposes.

Buyer Filter: Controls the customers (through B2B access) and salespeople (through sales-rep
access) that can view groups of products. (Also configured at the product level).

External ID: (Configure under Settings > Plugins > Authorize) Used for the Authorize.Net
integration. The External ID allows you to properly link your customer records in ApparelMagic Cloud
with your customer records in Authorize.Net. Generally this is filled in for you automatically by the
sync command.

Notes, Shipping Instructions: Used for transaction printouts.
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Customer Accounting
Configure accounting defaults for this customer

Price Group: After assigning a Price Group to the customer, you can assign a price to that group
under each product record.

Currency: This will automatically be specified on future transactions for the customer. You can
override the currency on a transaction if needed.

ApparelMagic Cloud Knowledge Base

Page 8ApparelMagic Cloud Knowledge Base



Managing External Credit Cards

In the same interface, the right section can be used to manage externally stored credit cards
associated with this customer. Only those gateways that have been enabled inside of the system
will appear in this section.
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Customer Locations
Use the Locations tab to add alternate Ship To locations for your customers.

Create a New Location

Select the plus sign in the bottom left hand corner to add a new location.
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A new window will appear to enter the new location

On future orders and transactions, you can select from these locations to specify where you want to
ship the order.

DC: Distribution Center, used if you have store locations that go through a Distribution Center. The
value is not often used and is normally a number.

Main Location: Allows for setting of a default location
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Customer Location List

You may also view a list of all locations entered in the system by navigating to Customers >
Locations. This information can be sorted, filtered, exported, and imported into from this list.

ApparelMagic Cloud Knowledge Base

Page 12ApparelMagic Cloud Knowledge Base



Customer People
The People tab allows you to keep all your contacts for a customer in one accessible place.

Create a new person

Select the plus sign in the bottom left hand corner to add a new person.
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A new window will appear to enter the person's information

Main Contact: The Main Contact for a customer is used for transaction printouts.

Send Email: This flag designates that this person should be included, by default, on all emails sent
to this company.

Web Access: Used to give customers access to ApparelMagic Cloud to view products and orders
directly in the system.
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Customer People List

You may also view a list of all people entered in the system by navigating to Customers > People.
This information can be sorted, filtered, exported, and imported into from this list.
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Customer Events
Keep track of all the events associated with the customer.

Add a new event

To create a new event, simply click the '+' button in the bottom left hand corner.
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A new window will appear to enter the new event

Type: Used to categorize events

Style, Order ID, Invoice ID: Associate a Style, Order, or Invoice with the event.
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Customer Salespeople
Any salesperson assigned under this tab will automatically be added to all future orders and invoices
for this customer

Create a new salesperson

Select the plus sign in the bottom left hand corner to add a new sales person.
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Enter the salesperson's default values for this customer

The default commission rate will be pulled from the Salesperson record under Settings > Dictionaries
> Salespeople but you can override the commission rate if needed.
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Customer Salespeople List

You may also view a list of all salespeople assigned as a default to customers in the system by
navigating to Customers > Salespeople. This information can be sorted, filtered, exported, and
imported into from this list.
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Customer Files
Once the DropBox plugin has been set up, you can drag and drop files to the Files tab to be linked
with the customer.

Simply drag and drop files to link them with the customer.
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Related Transactions
View transactions related to the customer.

Related Transaction Tabs

These tabs allow you to get a quick look at the most important transactions related to your
customers.
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Importing Customers
ApparelMagic Cloud offers the ability to import your customers from a spreadsheet.

Run the Import Customers command

Download the Customer template using the button below
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Modify the Template to include the Customer Information you are
trying to import

In this step, you should remove the sample data in the template and replace it with the customer
information you are trying to import. Make sure that you do not re-arrange or change any of the
columns in the existing spreadsheet, or you will receive an error when attempting to import this
information.

Drag and Drop the customer file on to the screen below
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Review the information displayed in the Review tab

Click Import to finalize the process
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Importing Locations
ApparelMagic Cloud offers the ability to import your customer locations from a spreadsheet.

Run the Import Locations command
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Download the Locations template using the button below

The Export > AM Template Format command can also be used to export location data for existing
locations in the system, so you can modify and update these locations.

Modify the template to include the Location Information you are trying
to import

In this step, you should remove the sample data in the template and replace it with the location
information you are trying to import. Make sure that you do not re-arrange or change any of the
columns in the existing spreadsheet, or you will receive an error when attempting to import this
information.
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Drag and drop the Location file on to the screen below

Review the information displayed in the Review tab
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Click Import to finalize the process
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Importing People
ApparelMagic Cloud offers the ability to import your customer contacts from a spreadsheet.

Run the Import People command
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Download the People template using the button below

The Export > AM Template Format command can also be used to export contact data for existing
people in the system, so you can modify and update these people.

Modify the template to include the People you are trying to import

In this step, you should remove the sample data in the template and replace it with the contact
information you are trying to import. Make sure that you do not re-arrange or change any of the
columns in the existing spreadsheet, or you will receive an error when attempting to import this
information.
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Drag and drop the People file on to the screen below

Review the information displayed in the Review tab
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Click Import to finalize the process
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Importing Customer Salespeople
ApparelMagic Cloud offers the ability to import your customer's default salespeople from a
spreadsheet.

Run the Import Customer Salespeople command
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Download the Customer Salespeople template using the button below

The Export > AM Template Format command can also be used to export contact data for existing
people in the system, so you can modify and update these assigned default salespeople.

Modify the template to include the Customer Salespeople defaults you
are trying to import

In this step, you should remove the sample data in the template and replace it with the contact
information you are trying to import. Make sure that you do not re-arrange or change any of the
columns in the existing spreadsheet, or you will receive an error when attempting to import this
information.

ApparelMagic Cloud Knowledge Base

Page 35ApparelMagic Cloud Knowledge Base



Drag and drop the Customer Salespeople file on to the screen below

Review the information displayed in the Review tab
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Click Import to finalize the process
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Importing RMS EDI Locations
The plugin that permits integration with RMS has simplified the process of importing RMS EDI
locations. Start by exporting the locations from your RMS software, which will generate an or.txt file
with customer address and shipping information.

Run Import Command

Click on Customers -> Actions -> Import -> RMS EDI Locations. Upload the or.txt file (by dragging
and dropping or clicking the red icon, selecting the file, then clicking open), review for errors, then
click import.

More information on the Customer Import Template

RMS EDI Locations are exported to ApparelMagic via a comma delimited text file that mirrors this
excel format. Please note the provided information on the following fields:

Customer_id (required): numeric identifier of customer in ApparelMagic, equal to the customers
"Account" number, which can be obtained from the Customer List. Must be included to associate
order with customer.

Address_1 (required): Only one of the two is necessary, but both may be imported

City, State, Zip, Country: All are required

Type: Defaulted to use "Ship to"
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Other RMS Integration Articles

The RMS integration can be used to import orders information into and export invoice information
from in ApparelMagic Cloud. Please see the knowledge base articles linked above for more
information.
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